Probleme mit der Tiled Gallery

Ein super ärgerliches Problem mit Jetpack bzw. der WordPress Tiled Gallery besteht hier seit langem, und nun eskaliert es. Grund ist, daß ich die Bild-Lade-Beschleunigung mittels des WordPress CDN (vormals „Photon“) im Jetpack Plugin jüngst abgestellt habe. Ich will wieder die Bildhoheit über meine Fotos, statt sie willkürlich WordPress zu überlassen, die lt. Supportanfrage nichtmal in der Lage sind, die schön sauber mit voller URL aufgelisteten Bilder eines gesamten Blogs (ca. 6000 bei mir) von ihren Servern zu löschen!
Aber es war klar, daß das alles nicht so einfach geht, und deshalb habe ich mittels Skripten meine WordPress Datenbank komplett von den WordPress CDN Bild-URLs gereinigt, so daß diese Server URLs in meinem gesamten WordPress nicht mehr vorkommen, und ich die Fotos nun wieder sicher lokal bedienen kann. Das wäre jedenfalls die Idee gewesen, und lt. Webdeveloper schaut es auch so aus. Leider kann ich meine teils großen Fotogalerien nun nicht mehr ändern, denn beim Editieren solcher Blogbeiträge kommt der im Artikelfoto gezeigte Fehler. Diesen hatte ich auch früher immer wieder, konnte es aber durch „Blockwiederherstellung“ fixen. Mache ich das jetzt, dann entstehen wie von Geisterhand wieder Image-URLs vom WordPress CDN, was ich absolut nicht verstehe, denn diese kommen in meiner gesamten WordPress DB nicht mehr vor. Woher kriegt er die also, und warum behauptet er, der Block wäre ohne die CDN URLs falsch? Soweit ich dies sehe, funktionieren meine Bildgalerien für User einwandfrei.
Es war ein richtiger Haufen Arbeit, da herumzuexperimentieren und alles mögliche auszuprobieren, und letztendlich scheint die einzige Lösung zu sein, nur die normale Non-Tiled Gallery im Blockeditor zu verwenden, oder aber auf ein externes Gallery Plugin zu gehen, was ich vermeiden will.
Sollte dieses Problem auch andere WordPress User betreffen, hier ein Tipp, wie man im Notfall schnell und auch brutal damit umgehen kann, wenn einen dieser Fehler plagt und man keine WordPress CDN URLs mehr will: Ich mache tatsächlich die Blockwiederherstellung, die mir die CDN URLs in der Galerie unerwünschterweise wieder zurückbringt. Unmittelbar danach wandle ich dann den Tiled Gallery Block in einen normalen Gallery Block um, was eben nur geht, wenn der obige Fehler nicht vorhanden ist. Daraufhin speichere ich und passe die neue Gallery (leider nicht tiled bzw. Mosaic-Layout) nach Wunsch an. Ab diesem Moment sind die WordPress CDN URLs wieder weg im Seitenquelltext und auch im Webdeveloper. Immerhin erspart mir dies, eine Galerie komplett neu aufzubauen.
Es sieht bei mir überraschenderweise so aus, als ob selbst nach dem Abschalten der Image Acceleration komplett neu erstellte Tiled Galleries dieses Problem haben. Ich erstelle eine komplett neue Tiled Gallery (ohne Image Acceleration Einstellung), und beim nächsten Bearbeiten des Artikels habe ich den obigen Fehler! Habe ich mir da in der Datenbank etwas ruiniert? Ich muß das gelegentlich an einer ganz neuen sauberen WordPress Installation testen. Fakt ist: es nervt gewaltig, und ich kann diese Funktionalität in Anbetracht solcher Probleme für langlaufende Blogs absolut nicht empfehlen. Das macht richtig Arbeit.
Nach 14 Jahren WordPress Blog muß ich sagen, würde ich mal gerne ein weniger aufgeblähtes System probieren. Speziell Kirby würde mich reizen. Vielleicht mache ich da mal einen Umstieg und lasse dieses Blog hier wenn überhaupt nurmehr als Legacy weiterlaufen, so gerne ich es auch selbst habe.
Auf jeden Fall überarbeite ich so nach und nach alle Artikel mit Tiled Gallery, sowie auch die ganz alten WordPress Galerien. Bis auf weiteres wird der ganz normale WordPress Gallery Block mit der Jetpack Karusell-Galerie verwendet, der gut zu funktionieren scheint, auch wenn er keine Mosaik-Anordnung der Bilder erlaubt.

Diesen Beitrag teilen

Schreiben Sie einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahren Sie mehr darüber, wie Ihre Kommentardaten verarbeitet werden .